ASA-2018-00079 – TYPO3: Cross-Site Scripting in Online Media Asset Rendering


Allele Security Alert

ASA-2018-00079

Identifier(s)

ASA-2018-00079, TYPO3-CORE-SA-2018-006

Title

Cross-Site Scripting in Online Media Asset Rendering

Vendor(s)

TYPO3 Association

Product(s)

TYPO3

Affected version(s)

TYPO3 7.5.0-7.6.31, 8.0.0-8.7.20 and 9.0.0-9.5.1

Fixed version(s)

TYPO3 versions 7.6.32, 8.7.21 or 9.5.2

Proof of concept

Unknown

Description

Failing to properly encode user input, online media asset rendering (*.youtube and *.vimeo files) is vulnerable to cross-site scripting. A valid backend user account or write access on the server system (e.g. SFTP) is needed in order to exploit this vulnerability.

Technical details

Unknown

Credits

András Ottó, Susanne Moog (TYPO3 core team) and Stefan Neufeind (TYPO3 core team)

Reference(s)

TYPO3 9.5.2, 8.7.21 and 7.6.32 security releases published
https://typo3.org/article/typo3-952-8721-and-7632-security-releases-published/

TYPO3-CORE-SA-2018-006: Cross-Site Scripting in Online Media Asset Rendering
https://typo3.org/security/advisory/typo3-core-sa-2018-006/

[SECURITY] Properly escape videoId for YouTube/Vimeo
https://github.com/TYPO3/TYPO3.CMS/commit/a32a9a746f807b14571139f0cb7caa00b8d037a5

[TYPO3-announce] Announcing TYPO3 v9.5.2, v8.7.21 and v7.6.32 security releases
http://lists.typo3.org/pipermail/typo3-announce/2018/000435.html

If there is any error in this alert or you wish a comprehensive analysis, let us know.

Last modified: February 1, 2019

We are not responsible for any data loss, device corruption or any other type of issue due to the use of any information mentioned in our security alerts.