ASA-2019-00166 – VMware: Out-of-bounds write vulnerability in e1000 and e1000e virtual network adapters


Allele Security Alert

ASA-2019-00166

Identifier(s)

ASA-2019-00166, CVE-2019-5515, VMSA-2019-0005

Title

Out-of-bounds write vulnerability in e1000 and e1000e virtual network adapters

Vendor(s)

VMware

Product(s)

VMware Workstation Pro / Player (Workstation)
VMware Fusion Pro / Fusion (Fusion)

Affected version(s)

VMware Workstation Pro / Player (Workstation) versions 15.x and 14.x
VMware Fusion Pro / Fusion (Fusion) running on OSX versions 11.x and 10.x

Fixed version(s)

VMware Workstation Pro / Player (Workstation) versions 15.0.3 and 14.1.6
VMware Fusion Pro / Fusion (Fusion) running on OSX versions 11.0.3 and 10.1.6

Proof of concept

Unknown

Description

VMware Workstation and Fusion updates address an out-of-bounds write vulnerability in the e1000 and e1000e virtual network adapters. Exploitation of this issue may lead to code execution on the host from the guest but it is more likely to result in a denial of service of the guest.

Technical details

Unknown

Credits

ZhanluLab

Reference(s)

[Security-announce] New VMSA-2019-0005 – VMware ESXi, Workstation and Fusion updates address multiple security issues
https://lists.vmware.com/pipermail/security-announce/2019/000454.html

VMSA-2019-0005
https://www.vmware.com/security/advisories/VMSA-2019-0005.html

CVE-2019-5515
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5515

CVE-2019-5515
https://nvd.nist.gov/vuln/detail/CVE-2019-5515

If there is any error in this alert or you wish a comprehensive analysis, let us know.

Last modified: April 2, 2019

We are not responsible for any data loss, device corruption or any other type of issue due to the use of any information mentioned in our security alerts.