ASA-2019-00180 – Magento: Arbitrary code execution due to unsafe deserialization of a PHP Archive


Allele Security Alert

ASA-2019-00180

Identifier(s)

ASA-2019-00180, PRODSECBUG-2256

Title

Arbitrary code execution due to unsafe deserialization of a PHP Archive

Vendor(s)

Magento

Product(s)

Magento

Affected version(s)

Magento 2.1 prior to 2.1.17
Magento 2.2 prior to 2.2.8
Magento 2.3 prior to 2.3.1

Fixed version(s)

Magento 2.1.17
Magento 2.2.8
Magento 2.3.1

Proof of concept

Unknown

Description

An authenticated user with privileges to configure email templates can execute arbitrary code via a PHP archive deserialization vulnerability.

Technical details

Unknown

Credits

Simon Scannell

Reference(s)

Magento 2.3.1, 2.2.8 and 2.1.17 Security Update
https://magento.com/security/patches/magento-2.3.1-2.2.8-and-2.1.17-security-update

If there is any error in this alert or you wish a comprehensive analysis, let us know.

Last modified: April 15, 2019

We are not responsible for any data loss, device corruption or any other type of issue due to the use of any information mentioned in our security alerts.