ASA-2019-00220 – GitLab: PDF.js vulnerable to CVE-2018-5158


Allele Security Alert

ASA-2019-00220

Identifier(s)

ASA-2019-00220

Title

PDF.js vulnerable to CVE-2018-5158

Vendor(s)

GitLab

Product(s)

GitLab Community Edition (CE)
GitLab Enterprise Edition (EE)

Affected version(s)

GitLab CE/EE 9.5 and later

Fixed version(s)

GitLab Community Edition (CE) and GitLab Enterprise Edition (EE) 11.9.4
GitLab Community Edition (CE) and GitLab Enterprise Edition (EE) 11.8.6
GitLab Community Edition (CE) and GitLab Enterprise Edition (EE) 11.7.10

Proof of concept

Unknown

Description

The version of PDF.js embedded in Gitlab is 1.8.172, which is vulnerable to CVE-2018-5158. Per the summary, attacker-supplied JavaScript will be executed in a web worker context.

Technical details

Unknown

Credits

certifiable

Reference(s)

GitLab Security Release: 11.9.4, 11.8.6, and 11.7.10
https://about.gitlab.com/2019/04/01/security-release-gitlab-11-dot-9-dot-4-released/

PDF Viewer will run code from PDF files, missing validation for /Domain and /Range parameters
https://bugzilla.mozilla.org/show_bug.cgi?id=1452075

CVE-2019-10640
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10640

CVE-2019-10640
https://nvd.nist.gov/vuln/detail/CVE-2019-10640

If there is any error in this alert or you wish a comprehensive analysis, let us know.

Last modified: April 24, 2019

We are not responsible for any data loss, device corruption or any other type of issue due to the use of any information mentioned in our security alerts.