ASA-2019-00260 – TYPO3: Cross-Site Scripting in Fluid Engine


Allele Security Alert

ASA-2019-00260

Identifier(s)

ASA-2019-00260, TYPO3-CORE-SA-2019-013

Title

Cross-Site Scripting in Fluid Engine

Vendor(s)

TYPO3 Association

Product(s)

TYPO3 CMS

Affected version(s)

TYPO3 CMS versions 8.0.0 up to 8.7.24
TYPO3 CMS versions 9.0.0 up to 9.5.5

Fixed version(s)

TYPO3 CMS versions 8.7.25 or 9.5.6

Proof of concept

Unknown

Description

It has been discovered that the Fluid Engine (package typo3fluid/fluid) is vulnerable to Cross-Site Scripting (XSS) when making use of the ternary conditional operator in templates like the following.

{showFullName ? fullName : defaultValue}

Technical details

Unknown

Credits

Bill Dagou

Reference(s)

TYPO3-CORE-SA-2019-013: Cross-Site Scripting in Fluid Engine
https://typo3.org/security/advisory/typo3-core-sa-2019-013/

TYPO3 9.5.6 and 8.7.25 security releases published
https://typo3.org/article/typo3-956-and-8725-security-releases-published/

[TYPO3-announce] Announcing TYPO3 v9.5.6 and v8.7.25 security releases
http://lists.typo3.org/pipermail/typo3-announce/2019/000442.html

If there is any error in this alert or you wish a comprehensive analysis, let us know.

Last modified: May 10, 2019

We are not responsible for any data loss, device corruption or any other type of issue due to the use of any information mentioned in our security alerts.