ASA-2019-00319 – phpMyAdmin: CSRF vulnerability in login form


Allele Security Alert

ASA-2019-00319

Identifier(s)

ASA-2019-00319, PMASA-2019-4, CVE-2019-12616

Title

CSRF vulnerability in login form

Vendor(s)

The phpMyAdmin Project

Product(s)

phpMyAdmin

Affected version(s)

All versions prior to phpMyAdmin 4.9.0 are affected, probably at least as old as version 4.0 (perhaps even earlier)

Fixed version(s)

phpMyAdmin 4.9.0

Proof of concept

Unknown

Description

A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim’s phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) through the victim.

Technical details

Unknown

Credits

Mauro Tempesta

Reference(s)

phpMyAdmin - Security - PMASA-2019-4
https://www.phpmyadmin.net/security/PMASA-2019-4

Retrieve parameters from $_POST in AuthenticationCookie plugin
https://github.com/phpmyadmin/phpmyadmin/commit/015c404038c44279d95b6430ee5a0dddc97691ec

CVE-2019-12616
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12616

CVE-2019-12616
https://nvd.nist.gov/vuln/detail/CVE-2019-12616

If there is any error in this alert or you wish a comprehensive analysis, let us know.

Last modified: June 7, 2019

We are not responsible for any data loss, device corruption or any other type of issue due to the use of any information mentioned in our security alerts.